Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#763 closed defect (invalid)

YAT_LT_LINK_IFELSE does not respect late changes to variables

Reported by: Peter Owned by: Peter
Priority: minor Milestone:
Component: m4 Version: trunk
Keywords: Cc:

Description

YAT_USE_LIBTOOL_PUSH contains

ac_link="./libtool --mode=link --tag=_YAT_USE_LIBTOOL_TAG $ac_link"

which is fine and $ac_link prior this typically is

'$CC -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'

The problem is that if we change any of the flags after YAT_USE_LIBTOOL_PUSH, we the change of the flags will not be reflected in the $ac_link which is confusing and suboptimal.

Change History (2)

comment:1 Changed 8 years ago by Peter

Resolution: invalid
Status: newclosed

comment:2 Changed 8 years ago by Peter

Milestone: yat 0.x+
Note: See TracTickets for help on using tickets.