Opened 7 years ago

Closed 7 years ago

#790 closed request (fixed)

workaround for BamPairIterator::operator->

Reported by: Peter Owned by: Peter
Priority: minor Milestone: yat 0.12
Component: omic Version: trunk
Keywords: Cc:

Description

As documented the operator doesn't work with older boost. Would it be possible to implement out own operator-> (when boost is old) to avoid the problem in base class.

Change History (4)

comment:1 Changed 7 years ago by Peter

Milestone: yat 0.x+yat 0.12
Priority: majorminor
Status: newassigned
Type: discussionrequest

comment:2 Changed 7 years ago by Peter

(In [3197]) refs #790. workaround for old boost

comment:3 Changed 7 years ago by Peter

(In [3198]) refs #790. Prefer checking (in configure) whether boost work rather than relying on version comparisons. The result of the configure test is stored in config_public.h which means an upgrade of boost is not sufficient to avoid the workaround, the user also need to re-configure yat (and install). That in turn means conditionals in header files are identical to the ones used when building libyat and any potential problems when conditionals are drifting away, changing declarations, and causing mysterious link errors are avoided.

comment:4 Changed 7 years ago by Peter

Resolution: fixed
Status: assignedclosed

(In [3199]) fixes #790

Note: See TracTickets for help on using tickets.