Opened 8 years ago

Closed 8 years ago

#823 closed defect (worksforme)

yat_m4_with_bam_test.sh fails

Reported by: Peter Owned by: Peter
Priority: major Milestone:
Component: test Version: trunk
Keywords: Cc:

Description

The highlights of the test log:

configure: "LDFLAGS:  -L/usr/lib64 -L/home/peterJo/local/lib"
configure: "LIBS:  /home/peterJo/projects/software/yat/htslib/yat/libyat.la -lgslcblas"
configure: creating ./config.lt
config.lt: creating libtool
checking for class BamInFile... no
configure: error: 

and from test's config.log

## ------------------ ##
## Running config.lt. ##
## ------------------ ##
config.lt:682: creating libtool
configure:17968: checking for class BamInFile
configure:17987: ./libtool --mode=link --tag=CXX g++ -o conftest -g -O2   -I/home/peterJo/projects/software/yat/htslib -I/home/peterJo/projects/software/yat/htslib/yat/utility -I/home/peterJo/projects/software/yat/htslib/.. -pthread -I/home/peterJo/local/include/  -L/usr/lib64 -L/home/peterJo/local/lib -L/usr/lib64 -L/home/peterJo/local/lib conftest.cpp  /home/peterJo/projects/software/yat/htslib/yat/libyat.la -lgslcblas -lyat -lhts -lz -lgsl -lboost_thread-mt -lboost_system -lgslcblas -lm >&5
libtool: link: g++ -o .libs/conftest -g -O2 -I/home/peterJo/projects/software/yat/htslib -I/home/peterJo/projects/software/yat/htslib/yat/utility -I/home/peterJo/projects/software/yat/htslib/.. -pthread -I/home/peterJo/local/include/ conftest.cpp  -L/usr/lib64 -L/home/peterJo/local/lib /home/peterJo/projects/software/yat/htslib/yat/.libs/libyat.so /home/peterJo/local/lib/libyat.so -lhts -lz -lgsl -lboost_thread-mt -lboost_system -lgslcblas -lm -pthread -Wl,-rpath -Wl,/home/peterJo/local/lib
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_index_destroy'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_iter_destroy'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_iter_read'
/home/peterJo/local/lib/libyat.so: undefined reference to `samclose'
/home/peterJo/local/lib/libyat.so: undefined reference to `samwrite'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_nt16_rev_table'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_iter_query'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_calend'
/home/peterJo/local/lib/libyat.so: undefined reference to `samopen'
/home/peterJo/local/lib/libyat.so: undefined reference to `bam_index_load'
/home/peterJo/local/lib/libyat.so: undefined reference to `samread'
collect2: ld returned 1 exit status

Attachments (1)

yat_m4_with_bam_test.log (43.2 KB) - added by Peter 8 years ago.
test log

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Peter

Attachment: yat_m4_with_bam_test.log added

test log

comment:1 Changed 8 years ago by Peter

Milestone: yat 0.13
Resolution: worksforme
Status: newclosed

The problem seems to be that libtool picked up and linked against both dev libyat and the installed libyat (in /usr/local) and the later was built against libbam and thus a tsunami of missed symbols...

-L/home/peterJo/local/lib /home/peterJo/projects/software/yat/htslib/yat/.libs/libyat.so /home/peterJo/local/lib/libyat.so

I cannot reproduce that, however, so I close this ticket.

Note: See TracTickets for help on using tickets.