#938 closed defect (fixed)

BamPairIterator does not pass test::Suite::input_iterator_test

Reported by: Peter Owned by: Jari Häkkinen
Priority: trivial Milestone: yat 0.18
Component: test Version: trunk
Keywords: Cc:

Description

The following line is commented out

//suite.test_input_iterator(piter);

Trying to compile that gives the following compiler error:

../test/Suite.h:588:10: error: no match for ‘operator==’ (operand types are ‘std::__iterator_traits<theplu::yat::omic::BamPairIterator2<theplu::yat::omic::BamReadIterator>, true>::value_type {aka theplu::yat::omic::BamPair}’ and ‘boost::iterator_facade<theplu::yat::omic::BamPairIterator2<theplu::yat::omic::BamReadIterator>, const theplu::yat::omic::BamPair, std::input_iterator_tag, const theplu::yat::omic::BamPairProxy, long int>::reference {aka const theplu::yat::omic::BamPairProxy}’)
   add(tmp==*iter);

Change History (2)

comment:1 Changed 17 months ago by Peter

Component: omictest
Milestone: yat 0.x+yat 0.18
Owner: changed from Peter to Jari Häkkinen
Priority: majortrivial

The problem is that Suite::test_trivial_iterator requires that ::value_type has an equality operator.

comment:2 Changed 17 months ago by Peter

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.